webbrowser [debian]

based on:
https://wiki.debian.org/WebBrowsers

1)Tor browser
2.1)min browser 32bit
2.2)min browser 64bit
3)palemoon 32bit/64bit
4)k-meleon
5)iceweasel
6)qupzilla
7.1) midori 32-bit
7.2) midori 64-bit
8)epiphany
9)dillo
10.1)iron 32bit
10.2)iron 64bit
11.1)vivaldi 32bit
11.2)vivaldi 64bit
12)install yandex browser
13)lynx
14)chromium
15)poseidon
16)browser addons
17)change default webbrowser


1)tor broswer:
sudo apt-get install torbrowser-launcher #Downloads are located in: ~/.local/share/torbrowser/tbb/x86_64/tor-browser_de/Browser/Downloads

2.1)install min browser 32-bit:
based on:
https://github.com/minbrowser/min/releases
get it and install it:
wget https://github.com/minbrowser/min/releases/download/v1.5.1/min_1.5.1_i386.deb
sudo dpkg -i min_*.deb

2.2)install min browser 64-bit:
get it and install it:
wget https://github.com/minbrowser/min/releases/download/v1.5.1/min_1.5.1_amd64.deb
sudo dpkg -i min_*.deb

3)palemoon:[ubuntu-mate 32bit/64bit]
based on:
https://www.palemoon.org/contributed-builds.shtml

install palemoon:
cd ~
mkdir .palemoonx
cd ~/.palemoonx
#wget http://linux.palemoon.org/files/pminstaller/0.2.2/pminstaller-0.2.2.tar.bz2
wget http://linux.palemoon.org/datastore/release/pminstaller-0.2.3.tar.bz2
tar -xjvf "pminstaller-0.2.3.tar.bz2"
./pminstaller.sh

(enter sudo password)
latest version->ok
Most preferred browser->ok
Exit pale moon for linux installer->ok

uninstall palemoon:
cd .palemoonx && ./pminstaller.sh

4) install k-meleon:
wget http://netcologne.dl.sourceforge.net/project/kmeleon/k-meleon/75.1/K-Meleon75.1.exe
wine K-Meleon75.1.exe

5)iceweasel:
sudo apt-get install -y iceweasel

6)qupzilla:
sudo apt-get install -y qupzilla

latest qupzilla [debian 64bit]:
sudo apt-get purge qupzilla -y
wget -O qupzilla_1.8.9_amd64.deb http://www.qupzilla.com/startdownload?debian64
sudo dpkg --install qupzilla*amd64.deb
rm qupzilla*amd64.deb

if you get an error like this:
dpkg: dependency problems prevent configuration of qupzilla:
qupzilla depends on libqt5core5a (>= 5.2.0); however:
Package libqt5core5a is not installed.
...
Errors were encountered while processing:
qupzilla

run the following line in terminal:
sudo apt-get install -f

latest qupzilla [ubuntu]:
sudo add-apt-repository ppa:nowrep/qupzilla
sudo apt-get update
sudo apt-get install qupzilla

remove qupzilla:
sudo apt-get purge qupzilla
sudo add-apt-repository --remove ppa:nowrep/qupzilla
sudo apt-get update

7.1) midori 32-bit:
wget http://midori-browser.org/downloads/midori_0.5.11-0_i386_.deb
sudo dpkg --install midori_*_amd64_.deb
rm midori_*_amd64_.deb
sudo apt-get install -f

7.2)midori 64-bit:
wget http://midori-browser.org/downloads/midori_0.5.11-0_amd64_.deb
sudo dpkg --install midori_*_amd64_.deb
rm midori_*_amd64_.deb
sudo apt-get install -f

8)epiphany:
sudo apt-get install -y epiphany-browser

9)dillo:
sudo apt-get install -y dillo

10.1)iron 32bit:
wget http://www.srware.net/downloads/iron.deb
sudo dpkg -i iron.deb
rm iron.deb

10.2)iron 64bit:
wget http://www.srware.net/downloads/iron64.deb
sudo dpkg -i iron64.deb
rm iron64.deb

remove iron:
sudo apt purge iron64

11.1)vivaldi 32bit:
sudo apt-get install -y libappindicator1
#wget https://downloads.vivaldi.com/stable/vivaldi-stable_1.2.490.39-1_i386.deb
wget https://downloads.vivaldi.com/stable/vivaldi-stable_1.6.689.46-1_i386.deb
sudo dpkg -i vivaldi-*_i386.deb
sudo apt-get install -f
rm vivaldi-*.deb

11.2)vivaldi 64bit:
sudo apt-get install -y libappindicator1
#wget https://downloads.vivaldi.com/stable/vivaldi-stable_1.2.490.39-1_amd64.deb
#wget https://downloads.vivaldi.com/stable/vivaldi-stable_1.6.689.46-1_amd64.deb

wget https://downloads.vivaldi.com/stable/vivaldi-stable_1.10.867.38-1_amd64.deb
sudo dpkg -i vivaldi-*_amd64.deb
sudo apt-get install -f
rm vivaldi-*.deb

remove vivaldi:
dpkg -l | grep 'vivaldi' #list
sudo dpkg -P vivaldi-preview #purge

12)install yandex browser beta [debian 64bit]
download the deb package from:
https://browser.yandex.com/desktop/main/?_rdr=safe

then simply install it:
sudo dpkg -i Yandex.deb

to remove it:
sudo apt-get purge yandex-browser-beta

13)lynx browser:
sudo apt-get install -y lynx #text-based webbrowser (start from terminal) lynx

14)chromium browser:
sudo apt install chromium #webbrowser

15)poseidon
https://github.com/sidus-dev/poseidon

16)browser addons:
https://fredfire1.wordpress.com/2013/08/18/browser-addons/

17)change default webbrowser:
check the default browser:
update-alternatives --query x-www-browser
change the default browser:
sudo update-alternatives --install /usr/bin/x-www-browser x-www-browser /usr/bin/palemoon 100
sudo update-alternatives --install /usr/bin/x-www-browser x-www-browser /usr/bin/vivaldi-stable 55

also change default browser here:
search on whiskermenu for “preferred applications” then choose the browser your want

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s